11.1 Usar la función “INDICE” + “COINCIDIR”

En este capitulo vamos a ver cуmo usar las funciones INDICE + COINCIDIR anidadas unas en otra.

1- Para ello vamos a copiar esta tabla

11.1 Usar la función “INDICE” + “COINCIDIR”

2- En unas celdas aparte copiamos estos datos:

Yaestudio

11.1 Usar la función “INDICE” + “COINCIDIR”
3- Ahora vamos a validar los datos.

4- Seleccionamos la celda a la derecha de PALABRA y vamos a Datos/Herramientas de datos/validación de datos y en la ventana que se nos abre de Validación de datos ponemos los siguientes datos.

• En Configuración/Criterio de Validación/Permitir y seleccionamos Lista.

• En Origen hacemos clic dentro de la casilla y seleccionamos todas las palabras en nuestra tabla en español. Nos tiene que quedar así.

11.1 Usar la función “INDICE” + “COINCIDIR”

Hacemos clic en Aceptar.

Y ya tenemos la lista desplegable en Palabra:

Devonn 

11.1 Usar la función “INDICE” + “COINCIDIR”

Ahora vamos a hacer lo mismo para la celda a la derecha de IDIOMA.

5- Seleccionamos la celda a la derecha de IDIOMA y vamos a Datos/Herramientas de datos/validaciуn de datos y en la ventana que se nos abre de Validaciуn de datos ponemos los siguientes datos.

• En Configuraciуn/Criterio de Validaciуn/Permitir y seleccionamos Lista.

• En Origen hacemos clic dentro de la casilla y seleccionamos todos los idiomas en nuestra tabla menos el espaсol. Nos tiene que quedar asi.

11.1 Usar la función “INDICE” + “COINCIDIR”

Hacemos clic en Aceptar.
Y ya tenemos la lista desplegable en IDIOMA:

11.1 Usar la función “INDICE” + “COINCIDIR”

Ahora en la celda al lado de TRADUCCIÓN vamos a insertar la función

11.1 Usar la función “INDICE” + “COINCIDIR”

1. INDICE(matriz;núm_fila;[núm_columna])

2. En matriz seleccionaremos todas las palabras de nuestra tabla menos las que están en español. Ahora ponemos punto y coma (;).

3. En núm_fila insertaremos la primera función COINCIDIR.

11.1 Usar la función “INDICE” + “COINCIDIR”

COINCIDIR (I) PALABRA

a) En Valor_buscado vamos a seleccionar la celda a la derecha de PALABRA (donde hicimos la validación de datos y tenemos nuestro desplegable) insertamos (;)
b) En matriz_buscada seleccionaremos todas las palabras de la columna español. Insertamos (;)
c) En Tipo_de_coincidencia seleccionaremos 0 para que nos dé una coincidencia exacta. Cerramos paréntesis e insertamos (😉

4. Ahora nos pide que introduzcamos la segunda parte de la función INDICE, en este caso es núm_columna.

5. Aquí vamos a anidar la segunda función COINCIDIR
COINCIDIR (II) IDIOMA

a) Escribimos COINCIDIR llamamos a la función y ponemos los siguientes datos:
b) En Valor_buscado vamos a seleccionar la celda a la derecha de IDIOMA (donde hicimos la validación de datos y tenemos nuestro desplegable) insertamos (;)
c) En matriz_buscada seleccionaremos todos los idiomas menos español de la primera fila. Insertamos (;)
d) En Tipo_de_coincidencia seleccionaremos 0 para que nos dé una coincidencia exacta. Cerramos paréntesis dos veces y damos clic en ENTER

Debería quedar algo así:

=INDICE(Tabla10[[Inglés]:[Gallego]];COINCIDIR(H11;Tabla10[Español];0);COINCIDIR(H12;Tabla10[[#Encabezados];[Inglés]:[Gallego]];0))

Si nuestra tabla fuera un rango, debería quedarnos algo así.

=INDICE(B2:F8;COINCIDIR(H11;A2:A8;0);COINCIDIR(H12;B1:F1;0))

Ahora ya podemos ir seleccionando palabras en el desplegable e idiomas y tenemos nuestro diccionario personal hecho en Excel

11.1 Usar la función “INDICE” + “COINCIDIR”.